PHP

In diesem Kapitel wird die Installation der verschiedenen PHP-Versionen für Apache beschrieben.

SQlite2-Unterstützung

Ab PHP 5.4.x wird SQlite2 nicht mehr unterstützt. Wer noch SQlite2 braucht, muss auf PHP 5.3.x downgraden.

Installation

1. Apache herunterladen und installieren, falls noch nicht geschehen.

2. Download des PHP-Binaries:

Für mipsel-Fritz!Boxen (z.B. 7270, 7170 und andere):

Für mips-Fritz!Boxen (z.B. 7390, 7340 und andere):

3. Das Binary muss in cgi-bin Verzeichnis kopiert werden. Danach wird das neue Binary aus dem Archiv in “php” umbenannt und ersetzt evtl. das alte Binary.

Außerdem muss das PHP-Binary ausführbar gemacht werden:

4. Zur Konfiguration wird die Datei conf/apache.conf verwendet. Meine apache.conf, die man im conf-Verzeichnis findet, muss nicht angepasst werden. Nach Aktualisieren der Seite sollte der Apache mit dem neuen Binary laufen.

Comments are closed.