PHP | Модификация Fritz!Box'ов

PHP

В этом разделе описана инсталляция PHP для веб-сервера Apache.

Поддержка SQlite2

PHP начиная с версии 5.4.x больше не поддержывает SQlite2. Тому, кому нужен SQlite2, должен проинсталирвать предыдущию версию PHP 5.3.x.

Инструкция по инсталляции

1. Скачать и инсталлировать Apache, если ещё не сделано.

2. Скачать бинарник PHP:

Для mipsel-Fritz!Box’ов (например 7270, 7170 и др.):

  • с поддержкой SQlite2
    • PHP 5.3.27
      Настройки: 

      • CURL support
      • GD support
      • ICONV support
      • JSON support
      • PCNTL support
      • SESSION support
      • SOCKETS support
      • SQLite (v2) support
      • SQLite (v3) support
      • SSL support
      • SYSVIPC support
      • XML support
      • ZIP support
    • PHP 5.3.26
    • PHP 5.3.22
    • PHP 5.3.20
    • PHP 5.3.16
  • без поддержки SQlite2

    Для mips-Fritz!Box’ов (например 7390, 7340 и др.):

    • с поддержкой SQlite2
      • PHP 5.3.27
        Настройки: 

        • CURL support
        • GD support
        • ICONV support
        • JSON support
        • PCNTL support
        • SESSION support
        • SOCKETS support
        • SQLite (v2) support
        • SQLite (v3) support
        • SSL support
        • SYSVIPC support
        • XML support
        • ZIP support
      • PHP 5.3.26
      • PHP 5.3.22
      • PHP 5.3.20
      • PHP 5.3.16
    • без поддержки SQlite2

    3. Бинарник нужно скопировать в директорию «cgi-bin». После этого нужно переименовать бинарник в «php», который заменит старый бинарник, если такой существует.

    Кроме этого бинарнику следует дать права на выполнение:


    4. Для конфигурации веб-сервера используется файл «conf/apache.conf». Мой apache.conf, который находится в директории «conf», поправлять не нужно. После перезагрузки страницы веб-сервер будет работать с новым бинарником.

Comments are closed.